NowGo not available in Apple App Store
Incident Report for Premonition
Resolved
NowGo is once again available from the Apple App Store. We'll continue to monitor, but don't expect any similar issues to occur again in future.
Posted Jun 01, 2021 - 17:14 AEST
Identified
At present NowGo is not available for download from the Apple App Store. Drivers who already have the app installed shouldn't be affected - only drivers trying to install it for the first time.

We are working to correct this, and will provide updates here as we progress.
Posted Jun 01, 2021 - 16:26 AEST
This incident affected: NowGo (NowGo Driver App).