NowGo Degraded performance

Incident Report for Premonition

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 16:45 AEDT

Update

We are continuing to monitor for any further issues.
Posted Oct 10, 2025 - 09:54 AEDT

Monitoring

A fix has been applied and we are monitoring the results
Posted Oct 10, 2025 - 09:51 AEDT

Investigating

We are investigating an issue affecting NowGo
Posted Oct 10, 2025 - 09:42 AEDT
This incident affected: NowGo (NowGo Dashboard, NowGo API).