NowGo Dashboard availability issue

Incident Report for Premonition

Resolved

We have resolved the issue
Posted Jun 26, 2025 - 16:22 AEST

Investigating

We are investigating an issue where some users are unable to load NowGo Dashboard
Posted Jun 26, 2025 - 16:18 AEST
This incident affected: NowGo (NowGo Dashboard).