Issue with logging into Driver App
Incident Report for Premonition
Resolved
We've addressed the underlying cause of this issue, and don't believe it will reoccur.

If anything doesn't seem right, please reach out to Support.
Posted Apr 20, 2023 - 15:50 AEST
Monitoring
Google have begun their rollback, and we've confirmed that it resolves the issue preventing users from launching the NowGo App.

Users who were affected should force-close the app or restart their device, and try to launch the app again.

At this state we don't believe an emergency release will be required, but we'll continue to prepare one as a contingency.
Posted Mar 30, 2023 - 09:38 AEDT
Update
Google are aware of the issue and have communicated that they are rolling back the problematic release. No timeline has been communicated.

We'll continue to prepare an emergency release as a contingency, and be in touch as soon as they are available.
Posted Mar 30, 2023 - 09:31 AEDT
Identified
We're aware of a major outage that's preventing users from launching the NowGo App.

We believe the issue is caused by either an incompatible update or a bug introduced to the Google Maps API, which was released at around 7:30 am this morning Sydney time. Our app loads the maps API on startup, to provide place names and address autocomplete.

In previous similar situations, we've seen Google promptly release fixes. However, as a contingency plan, we're preparing an emergency app release that will correct the issue.

For Android, the expected time to a release is one hour. For IOS, the release may take as long as 24 hours.

While we prepare the emergency release:
- Please ask drivers who are signed in to not sign out.
- Please ask drivers to update the app from the app store if prompted to do so.

We'll communicate when we begin the release process for each platform, and when we believe a rollout is complete.
Posted Mar 30, 2023 - 08:35 AEDT
Investigating
We have received reports of Drivers seeing a white screen that prevents them from logging in. We are currently investigating the issue.
Posted Mar 30, 2023 - 07:57 AEDT
This incident affected: NowGo (NowGo Driver App).