NowGo Outage

Incident Report for Premonition

Resolved

We've addressed the root cause of this incident and monitoring shows that NowGo is working normally. Please contact support if any further issues occur.
Posted May 08, 2026 - 11:47 AEST

Monitoring

We are aware of an issue that recently caused several minutes of unavailability for the NowGo API and dashboard. The issue also impacted some functionality in the NowGo Driver App, although offline functionality remained available.

We've resolved the cause of the issue and do not expect it to reoccur. We'll monitor closely to ensure the system is now stable.
Posted May 08, 2026 - 10:29 AEST
This incident affected: NowGo (NowGo Dashboard, NowGo API, NowGo Integrations, NowGo Driver App).