Problems receiving emails sent to Support
Incident Report for Premonition
Resolved
We've resolved the issue affecting incoming email to Support. We'll continue to monitor, but don't expect to see any further problems. If anything doesn't seem right please don't hesitate to get in touch so we can assist.
Posted Apr 20, 2022 - 16:10 AEST
Identified
We are aware of an issue preventing us from receiving emails to support@premonition.io. Messages are rejected with an error message from postmaster@premonition.io.

Until the issue is resolved, users can still access our support via https://support.premonition.io.

We're working on the problem and we'll provide updates here as we know more.
Posted Apr 20, 2022 - 12:40 AEST
This incident affected: Premonition Support.