Issues on NowGo API and dashboard

Incident Report for Premonition

Resolved

We've identified and resolved the root cause of this issue and don't expect it to reoccur. Please contact support for any assistance required.
Posted Jul 31, 2026 - 10:45 AEST

Monitoring

Our metrics indicate that all functionality has recovered. We're monitoring closely, and continuing to investigate the root cause of the issue.
Posted Jul 27, 2026 - 10:47 AEST

Investigating

We are currently investigating an issue impacting the NowGo API and dashboard. We'll provide more information here as it is available.
Posted Jul 27, 2026 - 10:43 AEST
This incident affected: NowGo (NowGo Dashboard, NowGo API, NowGo Driver App).